Sticky

Instagram FAQ: I can't connect my Instagram account to Manychat

  • 13 February 2024
  • 0 replies
  • 548 views

Userlevel 4
Badge

There can be several reasons for this issue. 

 

1. If it says Request sent, then this Instagram account is already connected to another Manychat account.

 

2. Check if there are no alerts here https://www.facebook.com/settings?tab=linked_instagram.

 

If 1 & 2 do not fix the issue, please do the following troubleshooting to check that your Instagram account is set up correctly to work with Manychat:

 

1. Make sure you have an Instagram Business account. In your Instagram mobile app, please go to Menu → Settings and privacy → Account type and tools select ‘Switch to professional account’ and follow the instructions. Here's a detailed guide for switching your account type.

 

2. Make sure that the Instagram account is linked to a Facebook Business Page you have full control of. In your Instagram mobile app, please go to Edit Profile Public business information → Page → Connect existing Page or Create Facebook Page. Here's a video guide.

 

3. If your Instagram account is linked to a Facebook page but its connection needs updating, you will see an alert in Meta Business Suite or on your page. Just click on the Get Started button and follow the prompts to review and update your connection.

cb1dkNLLSa6KuFsg16E3y7OK6C3Z7UJJy_garTKS3KrmfAMh6eLT2JJ7iEVpWkMPxXGaEl3zu8xCQH3xS0adHV2_VQgwR68ZZOezxFy4e7mIqPjSJN0JfDJNzTu-exGqaYt-i8DJn-Thle87PNq35WI

 

4. Confirm that Manychat can access messages on Instagram. Please open your Business account, go to Menu → Settings and Privacy  → Messages and story replies → Message controls, scroll down to Connected Tools and toggle ON Allow Access to Messages.

2Cdk5uwdUMHXGO0j_kxDJRCwe1ZRc7VZn8uX41IP1edPA_sAjeYP9PeKUPtDVsq6B0gKhcz93Udtn6x4yupI2F0GF6Ekz4Qd2l6l5hQ7m0vm1KuG462ejI8eoMALS6IajgaIrb-_AObrwO6MedSnFb4

 

5. In Settings → New Pages Experience → Advanced messaging →  Handover Protocol, assign the Primary Receiver role to Manychat.

aFixUYrDVGF_uxB8eTw-oOmnGKiDnBAEsPNhXid1M2yKldqC8zouGeq3V4ldVYlNEc11rsCCoPsJZjCLIlzkcxKsoR6YHKBLKOvwS5xIsmiWaOGZzmqZH6XY10-TNwiRMVxj5ElJneOrtdvA2EG-lrY

 

6. Check Age/Country restrictions on your Facebook page linked to the Instagram account.

UiARikkSA-X0-92Xb_PL4bE4JWWNFhxhFeo2QBhicHjfeiou770VqRiD0XQB2iZkwLhoyPBSNnmiF6z4IHhhSxTztm6lMyaoBCOp_I9QpD3iJeX9eJ7x_o6nW1VMLIY5xMDJljpMWsXYfSZNibcLQQw

 

7. Refresh Permissions in your Manychat account via the Help button:

STc5xn_Sl4P-EgI_PfdoedQFUM-_A2frIIibdCf3ZfiUJr1j8_KeiAg2jcN5wXDoSPaqdu_jIZMYUikT5P0eTv_SdlrwF4oMcdlnmor8gS2fL5s1EPHEhwu2Z7ZVihwi3C8bPpUdD0jfeCPHLvIJmsg

 

8. Please switch to your personal Facebook profile, go to your Business integrations https://www.facebook.com/settings?tab=business_tools, click on View and Edit next to Manychat, and make sure all permissions are granted.

If every toggle is already enabled there, try to toggle off the Manage your business option:

coDe0Z1rr7N1fHOAnvZ1aTKSV3pc9QgtxQyS5WVovH2tkrDPgi_zmUEUCmq9I7si-itx4LzwYJ3wWtbyHe1h6eK_7sSXH1uZQa49yvfJioLQdfrHT94O0JS43n0z5LiybGCHTJUpf2-LiIBU1YsHOw0

 

Then go to Manychat and refresh permissions through the Help button - it will take you here:

5pvJF6DiZTmI6dJHIMYdW2VHxobJRPfkWw3tJyjBkgxlJ5LFooxbF9CZKljtSfJzlJ-vTvkSuvUhaiv_i9j0ANJnALLSoO5CO5ORQJkgtqA-N-op5-1J3oWKeGlaONwRefM8RG1oHjpDsDYMwJT6y9Y

 

Click on Choose what you allow and make sure all the pages you manage are selected. Then, click Continue and see if it helps.

YZQRBzi-NVCtNE0bZvaC1fJsECPkjHTd8mUEbr15lE6IS6aloWg3s54co6n-3t0rvo0u2Ua0D0_cOYZqk6XKrW4uuQLMGlHph5_dahXDo08VA5G0gN1hMFP1tYwXSeahpeFoyzSvYD43wnLygavQk8E

 

 


This topic has been closed for comments